Lizenzfehler -17 (BricsCAD kann keine Verbindung zu einem Netzwerklizenzserver herstellen)

Symptome

Wir verwenden eine Netzwerklizenz. Wenn BricsCAD versucht, eine Verbindung zum Server herzustellen, wird der Fehler -17 gemeldet.

Ursache

Es handelt sich entweder um einen Virenscanner, eine Firewall oder einen Proxyserver.

Lösung

Bitte überprüfen Sie Folgendes:

  1. Ist eine TCP/UDP-Verbindung zwischen dem BricsCAD-Computer und dem Server möglich? Um die TCP-Verbindung zwischen dem BricsCAD-Computer und dem Netzwerklizenzserver zu testen, öffnen Sie ein Windows PowerShell-Terminal und führen Sie Folgendes aus:
    Test-NetConnection -computername <SERVERNAME> -port 5053
    Note: Ersetzen Sie <SERVERNAME> durch den Computernamen des Servers.
  2. Blockiert ein auf dem Server laufender Virenscanner den RLM-Dienst? Wenn ja, entsperren Sie es.
  3. Gibt es eine Firewall zwischen BricsCAD und dem Server? Wenn ja, öffnen Sie die Portnummer 5053 und die dem Bricsys-Lizenzserver zugewiesene Portnummer. Diese Portnummer wird beim Serverstart dynamisch zugewiesen. Sie können diese Portnummer auf der allgemeinen Status-Seite auf der Weboberfläche des RLM-Lizenzservers sehen.

    Sie können diese Portnummer definieren, indem Sie die nächste Zeile in der Lizenzdatei ändern:

    ISV bricsys in ISV bricsys port=die_Portnummer.

    Nach der Änderung muss das Serverprogramm (rlm.exe unter Windows, rlm unter Linux/OSX) heruntergefahren und neu gestartet werden.

    Wenn das Problem dadurch nicht behoben wird, fügen Sie das Programm rlm.exe als Ausnahme zu den Firewall-Ausnahmen hinzu. Starten Sie anschließend rlm.exe neu.

  4. Gibt es einen Proxyserver zwischen BricsCAD und dem Server? Erstellen Sie auf dem Computer, auf dem BricsCAD ausgeführt wird, die folgende(n) Systemvariable(n):
    • HTTP_PROXY=server:port
    • (optional) HTTP_PROXY_CREDENTIALS=Benutzername:Passwort, wenn der Proxyserver die grundlegende Authentifizierung unterstützt.
Note: Siehe auch den Artikel Erweiterte Konfigurationen.