Errore di licenza -17 (BricsCAD non è in grado di connettersi a un server licenze di rete)

Sintomi

Si sta utilizzando una licenza di rete. Quando BricsCAD tenta di connettersi al server, riporta l'errore -17.

Causa

È uno antivirus, un firewall o un server proxy.

Soluzione

Verificare quanto segue:

  1. È possibile una connessione TCP/UDP tra il computer con BricsCAD e il server? Per verificare la connessione TCP tra il computer con BricsCAD e il server delle licenze di rete, aprire un terminale Windows PowerShell ed eseguire:
    Test-NetConnection -computername <NOMESERVER> -port 5053
    Note: Sostituire <NOMESERVER> con il nome del computer del server.
  2. Un antivirus in esecuzione sul server sta bloccando il servizio RLM? In tal caso, sbloccalo.
  3. Esiste un firewall tra BricsCAD e il server? In tal caso, aprire la porta 5053 e il numero di porta assegnato al server delle licenze Bricsys. Questo numero di porta viene assegnato dinamicamente all'avvio del server. Il numero di porta è visibile nella pagina generale Status dell'interfaccia web del server licenze RLM.

    È possibile correggere il numero di porta modificando la seguente riga nel file di licenza:

    ISV bricsys in ISV bricsys port=il_numero_della_porta.

    Dopo aver modificato questa impostazione, il programma del server (rlm.exe su Windows, rlm su Linux/OSX) deve essere chiuso e riavviato.

    Se questo non risolve il problema, aggiungere il programma rlm.exe come eccezione alle eccezioni del firewall. Successivamente riavviare rlm.exe.

  4. C'è un server proxy tra BricsCAD e il server? Nel computer in cui è in esecuzione BricsCAD, creare le seguenti variabili di sistema:
    • HTTP_PROXY=server:porta
    • (opzionalmente) HTTP_PROXY_CREDENTIALS=username:password se il server proxy supporta l'autenticazione di base.
Note: Vedere anche l'articolo Configurazioni avanzate.