Błąd licencjonowania -17 (BricsCAD nie może połączyć się z serwerem licencji sieciowych)

Objawy

Korzystamy z licencji sieciowej. Kiedy BricsCAD próbuje połączyć się z serwerem, zgłasza błąd -17.

Przyczyna

Jest to skaner antywirusowy, zapora sieciowa lub serwer proxy.

Rozwiązanie

Sprawdź następujące elementy:

  1. Czy możliwe jest połączenie TCP/UDP między komputerem BricsCAD a serwerem? Aby przetestować połączenie TCP między komputerem BricsCAD a serwerem licencji sieciowych, otwórz terminal Windows PowerShell i uruchom:
    Test-NetConnection -nazwa_komputera <SERVERNAME> -port 5053
    Note: Zastąp ciąg <SERVERNAME> nazwą komputera serwera.
  2. Czy skaner antywirusowy uruchomiony na serwerze blokuje usługę RLM? Jeśli tak, odblokuj go.
  3. Czy istnieje zapora sieciowa między BricsCAD a serwerem? Jeśli tak, otwórz port o numerze 5053 i numer portu przypisany do serwera licencji Bricsys. Ten numer portu jest przypisywany dynamicznie podczas uruchamiania serwera. Ten numer portu można zobaczyć na ogólnej stronie Status w interfejsie internetowym serwera licencji RLM.

    Możesz naprawić ten numer portu, modyfikując następny wiersz w pliku licencji:

    bricsys port=the_port_number.

    Po zmianie tego parametru program serwerowy (rlm.exe w systemie Windows, rlm w systemie Linux/OSX) należy zamknąć i zrestartować.

    Jeśli to nie rozwiąże problemu, dodaj program rlm.exe jako wyjątek do wyjątków Zapory sieciowej. Po wykonaniu tej czynności uruchom rlm.exe ponownie.

  4. Czy między BricsCAD a serwerem jest serwer proxy? Na komputerze, na którym uruchomiony jest BricsCAD, utwórz następujące zmienne systemowe:
    • HTTP_PROXY=serwer:port
    • (opcjonalnie) HTTP_PROXY_CREDENTIALS=nazwa_uzytkownika:haslo jesli serwer proxy obsługuje uwierzytelnianie podstawowe.
Note: Zobacz też artykuł Konfiguracje zaawansowane.