Licensing error -17 (BricsCAD não pode se conectar a um servidor de licença de rede)
Sintomas
Estamos usando uma licença de rede. Quando o BricsCAD tenta se conectar ao servidor, ele relata o erro -17.
Causa
É um scanner de vírus, um firewall ou um servidor proxy.
Solução
Por favor, verifique o seguinte:
- É possível uma conexão TCP/UDP entre o computador BricsCAD e o servidor? Para testar a conexão TCP entre o computador BricsCAD e o servidor de licença de rede, abra um terminal Windows PowerShell e execute:
Test-NetConnection -computername <SERVERNAME> -port 5053
Note: Substitua <SERVERNAME> pelo nome do computador do servidor. - Há um verificador de vírus em execução no servidor bloqueando o serviço RLM? Em caso afirmativo, desbloqueie este.
- Existe um firewall entre o BricsCAD e o servidor? Nesse caso, abra a porta número 5053 e o número da porta atribuído ao servidor de licenças Bricsys. Esse número de porta é atribuído dinamicamente quando o servidor é iniciado. Você pode ver esse número de porta na página geral Status na interface da Web do servidor de licença RLM.
Você pode corrigir esse número de porta modificando a próxima linha no arquivo de licença:
ISV bricsys
intoISV bricsys port=the_port_number
.Após alterar isso, o programa do servidor (rlm.exe no Windows, rlm no Linux/Mac) precisa ser desligado e reiniciado.
Se isso não resolver, adicione o programa 'rlm.exe' como exceção nas exceções do Firewall. Reinicie o rlm.exe depois de fazer isso.
- Existe um servidor proxy entre o BricsCAD e o servidor? No computador onde o BricsCAD está sendo executado, crie as seguintes variáveis de sistema:
- HTTP_PROXY=server:port
- (opcionalmente) HTTP_PROXY_CREDENTIALS=username:password se o servidor proxy suportar autenticação básica.
Note: Consulte também o artigo Configurações avançadas.