Licensing error -18 (No license for this product on the license server. Please contact your license administrator)

Symptoms

We are using a network license. When BricsCAD tries to connect to the server it reports No license for this product on the license server. Please contact your license administrator (error code -18).

Cause

One possible cause could be that the hostid has changed and no longer matches the hostid of the server it is running on.

Solution

Try the following steps:

  • Revoke the activation.
  • Delete the current Bricsys.lic file (located in C:\Program Files\Bricsys\Bricsys Network License Manager).
  • Run actNetworkLicense.exe, enter the license key and activate.
  • Once the key is activated and the .lic file is created, go to the web interface of the licensemanager and perform a Reread/restart.