Quais arquivos incluir ao relatar falhas?

Sintomas

Você experimentou uma falha no programa, ou o programa trava com frequência.

Causa

A maneira mais confiável de relatar uma falha é fornecer um cenário repetível. Isso significa que um procedimento passo a passo é fornecido junto com um contexto inicial bem definido. Isso pode exigir algum esforço para acertar, mas tem, de longe, as maiores chances de sucesso.

Em geral, para tornar um cenário repetível, é melhor reduzir o ambiente para ser o mais padrão possível. Este é um processo de simplificação e eliminação. Se possível, um cenário deve começar com um perfil de usuário BricsCAD predefinido, um novo desenho, sem plug-ins de terceiros ou personalização do usuário, e um arquivo *.cui predefinido.

Se não for possível fornecer um cenário repetitivo, então em alguns casos se pode deduzir informações suficientes de arquivos de diagnóstico adicionais.

Solução

Envie uma solicitação de suporte incluindo arquivos como:

  • crash_report.txt
    Note:
    • O crash_report.txt é criado no Windows e, a partir do BricsCAD V24.2.02, também no Linux.
    • No macOS, há o arquivo bricscad-YYYY-MM-DD-xxxxxxxx.ips gerado pelo sistema operacional.
  • Arquivo Crash dump (.dmp)
  • Perfil do usuário.

    As configurações atuais do perfil do usuário podem ser exportadas para um arquivo usando o Gerenciador do Perfil.

  • Arquivo de desenho.

    Se uma falha for específica para um desenho, então esse desenho será útil.

  • Descreva o efeito do Modo de Segurança.

    Se o problema desaparecer durante a execução no Modo de Segurança, pode ser útil voltar ao Modo Normal e desativar ou desinstalar plug-ins e personalizações para restringir a possível causa.

  • Arquivo de log (raramente solicitado).
Note:

A palavra crash (falha) é muitas vezes mal utilizada para outros problemas, então o analista pode fazer perguntas para definir exatamente o que acontece. Um travamento ou congelamento não é um bloqueio (crash), e uma operação extremamente lenta não é um travamento. Uma operação que falha com um erro, mas não fecha o BricsCAD, também não é uma falha (crash).

Um relatório de falha (crash) é gravado no arquivo crash_report.txt cada vez que o BricsCAD sofrer um bloqueio. O relatório de falha é salvo na pasta de inicialização do BricsCAD. A localização desta pasta depende de como você inicia o BricsCAD, portanto, esteja ciente de que vários arquivos podem existir em seu sistema, em pastas diferentes. Se o programa não tiver permissão para criar o arquivo na pasta de inicialização, o arquivo será criado na pasta %HOMEPATH% (em Windows, normalmente é c:\Users\[username]\). Algumas vezes o relatório de falha é gerado sem o programa ser fechado. Algumas vezes ocorre uma falha, e não é emitido um relatório de falha.

(Específico do Windows) Na maioria dos casos, uma falha de programa resulta em um arquivo crash dump (.dmp) (despejo), que é gerado na mesma pasta que o crash_report.txt. A criação de um arquivo de despejo (dump) de memória pode ser ativada ou desativada dependendo do bit 2048 na variável de sistema QAFLAGS. Antes da V18.2, o dump de travamento era criado apenas se o bit 2048 QAFLAGS estivesse definido. Em versões mais recentes, o significado do sinalizador foi invertido, e o arquivo de despejo de memória agora é criado por predefinição.

O BricsCAD pode registrar cada comando executado em um arquivo de log texto. A geração desse arquivo 'log' é controlada pela variável de sistema LOGFILEMODE. Se LOGFILEMODE = 1, um arquivo de log é criado toda vez que um desenho é aberto. O formato do nome do arquivo é NomeDesenho_yyyy-mm-dd_hh-mm-ss.log.

Arquivos de log do BricsCAD são salvos na pasta especificada pela variável de sistema LOGFILEPATH. Por padrão, esta é a pasta apontada pela variável de sistema LOCALROOTPREFIX.