Licensing error -17 (BricsCAD cannot connect to the network license server)

Symptoms

BricsCAD displays error -17 when attempting to connect to the Network License Server.

Cause

Possible causes:

  • Firewalls, proxy servers, anti-virus software and other security measures can block the ports used by the Network License Server.
  • The Network License Server is down.

Solution

  • First, make sure that the BricsCAD computer:
    • Is on the same Local Area Network (LAN) with the Network License Server, either physically or via VPN.
    • Is able to communicate with the Network License Server on port 5053 and the ISV port over TCP/UDP.

    Then test the connection between the BricsCAD computer and the network license server. Open a Windows PowerShell terminal and run:

    Test-NetConnection -computername <SERVERNAME> -port <NUMBER>
    Note: Adapt and insert the line above for port 5053, then repeat it for the ISV port. On both lines, replace <SERVERNAME> with the server name and <NUMBER> with the specific port number.

    If the connection fails, you need to open port 5053 and the ISV port. For more information, see the Advanced configurations article.

  • Make sure the anti-virus software is not blocking the RLM service on the Network License Server.
  • If there is a proxy server between the BricsCAD computer and the Network License Server create the following system variable(s):
    • HTTP_PROXY=server:port
    • (optionally) HTTP_PROXY_CREDENTIALS=username:password if the proxy server supports basic authentication.