Error de licencia -17 (BricsCAD no puede conectarse a un servidor de licencias de red)

Síntomas

Estamos utilizando una licencia de red. Cuando BricsCAD intenta conectarse al servidor, informa el error -17.

Causa

Es un escáner de virus, un cortafuegos o un servidor proxy.

Soluciones

Por favor revisa lo siguiente:

  1. ¿Es posible una conexión TCP/UDP entre el ordenador BricsCAD y el servidor? Para probar la conexión TCP entre el ordenador BricsCAD y el servidor de licencias de red, abra una terminal de Windows PowerShell y ejecute:
    Test-NetConnection -nombre de computadora <SERVERNAME> -puerto 5053
    Note: Reemplace <SERVERNAME> con el nombre del ordenador del servidor.
  2. ¿Se está ejecutando un detector de virus en el servidor que bloquea el servicio RLM? Si es así, desbloquéelo.
  3. ¿Hay un firewall entre BricsCAD y el servidor? Si es así, abra el puerto número 5053 y el número de puerto asignado al servidor de licencias de Bricsys. Este número de puerto se asigna dinámicamente cuando se inicia el servidor. Puede ver este número de puerto en la página general Estado en la interfaz web del servidor de licencias RLM.

    Puede corregir ese número de puerto modificando la siguiente línea en el archivo de licencia:

    ISV bricsys en ISV bricsys port=the_port_number.

    Después de cambiar esto, el programa del servidor (rlm.exe en Windows, rlm en Linux/OSX) debe cerrarse y reiniciarse.

    Si esto no lo resuelve, agregue el programa rlm.exe como una excepción en las excepciones del Firewall. Reinicie rlm.exe después de hacer eso.

  4. ¿Hay un servidor proxy entre BricsCAD y el servidor? En el ordenador donde se ejecuta BricsCAD, cree las siguientes variables del sistema:
    • HTTP_PROXY=servidor:puerto
    • (opcionalmente) HTTP_PROXY_CREDENTIALS=nombre de usuario:contraseña si el servidor proxy admite la autenticación básica.
Note: Consulte también el artículo Configuraciones avanzadas.