¿Cómo evitar que BricsCAD se bloquee durante el inicio?

Síntomas

El programa se bloquea al iniciar. Los bloqueos pueden comenzar repentinamente sin motivo aparente, o después de algunas actualizaciones del sistema o del programa.

Causa

Puede haber muchas causas. El propósito de este elemento es ofrecer una lista de verificación rápida que le permita solucionar el bloqueo por su cuenta o informar del incidente para que podamos darle seguimiento.

Soluciones

  • La instalación del programa está dañada. Por sí sola, una instalación dañada es algo muy poco común, y reinstalar sin más no suele resolver el problema. Lo que suele ocurrir es que un antivirus demasiado estricto (normalmente Norton Autoprotect) ha puesto en cuarentena uno o más archivos DLL que considera sospechosos, lo que impide que BricsCAD® se inicie o, en algunos casos, provoca la pérdida de funcionalidades. La solución, entonces, consiste en resolver el conflicto con el antivirus: comprobar si realmente ha generado un falso positivo y añadir una excepción en el antivirus. A continuación, arregle la instalación, por ejemplo, reinstalando.
  • La configuración del programa es mala. La configuración de un programa experimenta una evolución a lo largo de sus versiones, y es posible que, tras una actualización, una nueva versión de BricsCAD® se encuentre con algo que no puede gestionar.
  • Es posible que el registro COM de BricsCAD® esté dañado. Esto puede ocurrir por diversas razones y provocar fallos extraños en el funcionamiento del programa, llegando incluso a bloqueos y errores en aplicaciones de terceros. Para volver a registrar correctamente la interfaz COM, active la casilla ejecutar como administrador en el acceso directo del escritorio - normalmente basta con iniciar BricsCAD® una vez con esta opción activada. Si hay instaladas varias versiones de BricsCAD® y/o versiones x86 y x64 en la misma máquina, es obligatorio tener activada la opción ejecutar como administrador ya que cada versión y plataforma de BricsCAD® tiene su propia interfaz COM.
  • Es posible que el perfil de BricsCAD® que almacena la configuración entre sesiones de BricsCAD® (y se guarda en el registro de Windows), haya terminado conteniendo valores que el programa no puede gestionar. Esto se puede verificar iniciando BricsCAD® con un perfil limpio bricscad.exe /p newprofilename. Esto se puede hacer en la línea de comandos de Windows, editando el acceso directo de BricsCAD® o utilizando la herramienta independiente BricsCAD® ProfileManager (profilemanager_app.exe). Este enfoque no elimina el perfil original, por lo que puede recuperarse si es necesario o adjuntarse a una solicitud de soporte para diagnóstico, incluso si el usuario logró evitar el bloqueo inmediato. Al comenzar con un nuevo dibujo, seleccione una plantilla de dibujo en 2D para excluir el posible impacto de los problemas de RedSdk. Las plantillas BIM y Mechanical utilizan Redsdk.
  • Tal vez uno de los archivos de recursos (classic-ribbon.cui, archivos lisp, archivo PGP, etc.) no se puede cargar correctamente. Para verificar esto rápidamente, intente cambiar el nombre de la carpeta:
    %APPDATA%\Bricsys\BricsCAD\V25x64\en_US\Support
    Si BricsCAD® inicia (aunque de forma limitada), entonces ha acotado el problema a esta carpeta y puede intentar renombrarla de nuevo e ir moviendo o renombrando su contenido poco a poco, empezando por el archivo CUI
  • Tal vez una aplicación de terceros provoque el bloqueo. Los métodos anteriores ya desactivarán la mayoría de las aplicaciones de terceros, pero puede que se necesiten acciones adicionales para desactivarlas por completo.
  • O es más complicado. Entonces presente una solicitud de soporte.
    Agregue archivos de registro e informes de bloqueo cuando se produzcan bloqueos.
Nota: Inicie BricsCAD® en modo seguro. Si el problema desaparece, puede ser útil volver al modo normal y desactivar o desinstalar los complementos y personalizaciones para identificar la causa del fallo.