¿Cómo evitar que BricsCAD se bloquee durante el inicio?
Síntomas
El programa se bloquea al iniciar. Los bloqueos pueden comenzar repentinamente sin motivo aparente, o después de algunas actualizaciones del sistema o del programa.
Causa
Puede haber muchas causas. El propósito de este elemento es ofrecer una lista de verificación rápida que le permita solucionar el bloqueo por su cuenta o informar del incidente para que podamos darle seguimiento.
Soluciones
- La instalación del programa está dañada. Por sí sola, una instalación dañada es muy poco común e intentar reinstalar sin más no funcionará. Lo que ocurre es que un antivirus demasiado estricto (normalmente Norton Autoprotect) ha puesto en cuarentena uno o varios archivos DLL que considera sospechosos, lo que provoca que BricsCAD ya no se inicie o, en ocasiones, pierda funcionalidad. El enfoque entonces consiste en resolver este conflicto con el antivirus: determine si el antivirus efectivamente causó un falso positivo y añada una excepción al antivirus. A continuación, repare la instalación, por ejemplo, reinstalando.
- La configuración del programa es incorrecta. La configuración de un programa acumula un historial de cambios a lo largo de las versiones, y es posible que, después de una actualización, una nueva versión de BricsCAD encuentre algo que no pueda gestionar.
- Es posible que el registro COM de BricsCAD esté dañado, esto puede ocurrir por varias razones y puede provocar errores y comportamientos muy extraños, incluso fallos del programa y fallos en aplicaciones de terceros. Para volver a registrar correctamente la interfaz COM, active la casilla ejecutar como administrador en el acceso directo del escritorio - normalmente basta con iniciar BricsCAD una vez con esta opción activada. Si hay varias versiones de BricsCAD y/o versiones x86 y x64 instaladas en el mismo equipo, entonces es obligatorio tener habilitada la opción ejecutar como administrador, porque cada versión y plataforma de BricsCAD tiene su propia interfaz COM.
- Es posible que el perfil de BricsCAD que almacena la configuración entre sesiones de BricsCAD (el perfil de usuario se almacena en el registro de Windows), haya acabado conteniendo valores que el programa no puede gestionar. Esto puede verificarse iniciando BricsCAD bricscad con un perfil limpio bricscad.exe /p newprofilename. Esto puede hacerse en la línea de comandos de Windows, editando el acceso directo de BricsCAD, o utilizando la herramienta independiente ProfileManager de BricsCAD (profilemanager_app.exe). Este método no elimina el perfil original, por lo que puede recuperarse si es necesario o adjuntarse a una solicitud de soporte para diagnóstico, incluso si el usuario logró evitar el bloqueo inmediato. Al comenzar con un nuevo dibujo, seleccione una plantilla de dibujo en 2D para excluir el posible impacto de los problemas de RedSdk. Las plantillas BIM y Mechanical utilizan Redsdk.
- Tal vez uno de los archivos de recursos (default.cui, archivos lisp, archivo PGP, etc.) No se puede cargar correctamente. Para verificar esto rápidamente, intente cambiar el nombre de la carpeta:%APPDATA%\Bricsys\BricsCAD\V26x64\en_US\SupportSi BricsCAD se inicia (aunque sea de forma limitada), entonces habrá localizado el problema en esta carpeta y puede intentar volver a cambiarle el nombre y mover/renombrar su contenido por partes, empezando por el archivo CUI.
- Tal vez una aplicación de terceros provoque el bloqueo. Los métodos anteriores ya desactivarán la mayoría de las aplicaciones de terceros, pero puede que se necesiten acciones adicionales para desactivarlas por completo.
- O es más complicado. Entonces presente una solicitud de soporte.Agregue archivos de registro e informes de bloqueo cuando se produzcan bloqueos.
Nota: Inicie BricsCAD en Modo Seguro. Si el problema desaparece, puede ser útil volver al modo normal y desactivar o desinstalar los complementos y personalizaciones para identificar la causa del fallo.