Erreur de licence -17 (BricsCAD ne peut pas se connecter au serveur de licence réseau)

Symptômes

BricsCAD affiche l'erreur -17 lors de la tentative de connexion au serveur de licences réseau.

Cause

Causes possibles :

  • Les pare-feux, les serveurs proxy, les logiciels antivirus et d'autres mesures de sécurité peuvent bloquer les ports utilisés par le serveur de licences réseau.
  • Le serveur de licences réseau est hors service.

Solution

  • Tout d'abord, assurez-vous que l'ordinateur BricsCAD :
    • se trouve sur le même réseau local (LAN) que le serveur de licences réseau, soit physiquement, soit par l'intermédiaire d'un VPN.
    • est capable de communiquer avec le serveur de licences réseau sur le port 5053 et le port ISV via TCP/UDP.

    Testez ensuite la connexion entre l'ordinateur BricsCAD et le serveur de licences réseau. Ouvrez un terminal Windows PowerShell et exécutez :

    Test-NetConnection -computername <SERVERNAME> -port <NUMBER>
    Remarque : Adaptez et insérez la ligne ci-dessus pour le port 5053, puis répétez-la pour le port ISV. Sur les deux lignes, remplacez <SERVERNAME> par le nom du serveur et <NUMBER> par le numéro de port spécifique.

    Si la connexion échoue, vous devez ouvrir le port 5053 et le port ISV. Pour plus d'informations, voir l'article Configurations avancées.

  • Assurez-vous que le logiciel antivirus ne bloque pas le service RLM sur le serveur de licences réseau.
  • S'il existe un serveur proxy entre l'ordinateur BricsCAD et le serveur de licences réseau, créez les variables système suivantes :
    • HTTP_PROXY=serveur:port
    • (facultativement) HTTP_PROXY_CREDENTIALS=nom d'utilisateur:mot de passe si le serveur proxy prend en charge l'authentification de base.