Pourquoi les clés de carte ESRI ne fonctionnent-elles plus ?
Symptômes
Lorsque j'essaie d'utiliser une carte ESRI, j'obtiens le message d'erreur « Server service is unavailable or Invalid ESRI Maps Key » (Le service du serveur est indisponible ou la clé de cartes ESRI n'est pas valide) dans le coin inférieur droit de l'écran.

Cause
Causes possibles :
- Le 26 février 2025, ESRI a modifié ses extrémités pour les cartes ESRI urbaine, ESRI claire et ESRI foncée.
Lorsque vous utilisez BricsCAD V24.2.X et V25.1.X, vous rencontrez une erreur « Server service is unavailable or Invalid ESRI Maps Key » (Le service du serveur est indisponible ou la clé de cartes ESRI n'est pas valide) lorsque vous essayez d'utiliser ces cartes.
- La clé API a expiré.
- La clé API comporte des URL de référent.
Solution
- Pour résoudre ce problème pour les versions de BricsCAD mentionnées, vous devez manuellement mettre à jour les extrémités dans la section Services de cartographie en ligne de la boîte de dialogue Paramètres.
Les nouvelles extrémités doivent être définies comme suit :
- Métadonnées urbaines statiques : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/streets/static
- Tuile urbaine statique : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/streets/static/tile/{level}/{row}/{column}
- Métadonnées en gris clair statiques : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/light-gray/static
- Tuile en gris clair statique : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/light-gray/static/tile/{level}/{row}/{column}
- Métadonnées en gris foncé statiques : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/dark-gray/static
- Tuile en gris foncé statique : https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/dark-gray/static/tile/{level}/{row}/{column}
- Pour savoir si votre clé API a expiré, vous devez accéder aux identifiants de votre clé API. Si votre clé a expiré, vous pouvez en générer une nouvelle.
- Pour savoir si votre clé API contient des URL de référent, vous devez accéder aux identifiants de votre clé API. Si des entrées sont répertoriées, elles doivent être supprimées.Remarque : Mise à jour des référents invalides de votre clé API Si vous modifiez les référents, vous devez également régénérer votre clé existante ou en générer une nouvelle.
Comment accéder aux identifiants de votre clé API ?
- Connectez-vous à votre compte sur la ArcGIS Location Platform. Cliquez sur le bouton Sign in (S'inscrire) (1).
- Une fois que vous vous êtes connecté au tableau de bord de la ArcGIS Location Platform, faites défiler la page vers le bas jusqu'à Developer credentials (Identifiants développeur) (2). Choisissez la clé API appropriée et cliquez sur le bouton Manage credential (Gérer les identifiants) (3).
- Un nouvel onglet de navigateur avec la clé API Overview s'ouvre. Sélectionnez Paramètres (4) en haut à droite de la page.
- Vous pouvez maintenant consulter ou modifier les paramètres de votre clé API.
Faites défiler la page vers le bas jusqu'aux API keys (Clés API) (5) pour vérifier la date d'expiration ou jusqu'aux Referrers (Référents) (6) pour voir s'il y a des entrées répertoriées.