Errore di licenza -17 (BricsCAD non è in grado di connettersi a un server delle licenze di rete)

Sintomi

BricsCAD mostra l'errore -17 quando si tenta di connettersi al Server delle Licenze di Rete.

Causa

Possibili cause:

  • Firewall, server proxy, software antivirus e altre misure di sicurezza possono bloccare le porte utilizzate dal Server delle Licenze di Rete.
  • Il Server delle Licenze di Rete è fuori uso.

Soluzione

  • Per prima cosa, assicurarsi che il computer con BricsCAD:
    • È sulla stessa Rete Locale (LAN) del Server delle Licenze di Rete, sia fisicamente che tramite VPN.
    • È in grado di comunicare con il Server delle Licenze di Rete tramite la porta 5053 e la porta ISV via TCP/UDP.

    Poi testare la connessione tra il computer con BricsCAD e il server delle licenze di rete. Aprire il terminale PowerShell di Windows e eseguire:

    Test-NetConnection -computername <SERVERNAME> -port <NUMBER>
    Nota: Adattare e inserire la stringa sopra per la porta 5053, poi ripetere per la porta ISV. Su entrambe le stringhe, sostituire <SERVERNAME> con il nome del server e <NUMBER> con il numero di porta specifico.

    Se la connessione fallisce, bisognerà aprire la porta 5053 e la porta ISV. Per ulteriori informazioni, consultare l'articolo sulle Configurazioni avanzate.

  • Assicurarsi che il software antivirus non stia bloccando il servizio RLM sul Server delle Licenze di Rete.
  • Se esiste un server proxy tra il computer di BricsCAD e il Server delle Licenze di Rete, creare la seguente variabile di sistema:
    • HTTP_PROXY=server:porta
    • (opzionalmente) HTTP_PROXY_CREDENTIALS=username:password se il server proxy supporta l'autenticazione di base.