ライセンスエラー-17(BricsCADはネットワークライセンスサーバーに接続できません)
症状
ネットワークライセンスを使用しています。 BricsCADがサーバーに接続しようとすると、エラー-17が報告されます。
原因
ウイルス スキャナー、ファイアウォール、またはプロキシ サーバーのいずれかです。
ソリューション
以下のことを確認してください:
- BricsCAD コンピューターとサーバー間で TCP/UDP 接続は可能ですか?BricsCAD コンピューターとネットワーク ライセンス サーバー間の TCP 接続をテストするには、Windows PowerShell ターミナルを開いて次のコマンドを実行します。
Test-NetConnection -computername <SERVERNAME> -port 5053Note: <SERVERNAME> をサーバーのコンピューター名に置き換えます。 - サーバー上で実行されているウイルス スキャナーが RLM サービスをブロックしていますか?もしそうなら、ブロックを解除してください。
- BricsCAD とサーバーの間にファイアウォールはありますか?その場合は、ポート番号 5053 と、Bricsys ライセンス サーバーに割り当てられたポート番号を開きます。このポート番号は、サーバーの起動時に動的に割り当てられます。このポート番号は、RLM ライセンス サーバーの Web インターフェイスの一般的なステータスページで確認できます。
ライセンス ファイルの次の行を変更することで、そのポート番号を修正できます。
ISV bricsysintoISV bricsys port=the_port_number.これを変更した後、サーバー プログラム (Windows の場合は rlm.exe、Linux/OSX の場合は rlm) をシャットダウンして再起動する必要があります。
それでも解決しない場合は、プログラム rlm.exe をファイアウォールの例外として追加します。その後、rlm.exe を再起動します。
- BricsCAD とサーバーの間にプロキシ サーバーはありますか?BricsCAD を実行しているコンピューターで、次のシステム変数を作成します。
- HTTP_PROXY=server:port
- (オプション) プロキシ サーバーが基本認証をサポートしている場合は、HTTP_PROXY_CREDENTIALS=username:password。
Note: 高度な構成に関する記事も参照してください。

