Dlaczego klucze map ESRI już nie działają?

Objawy

Podczas próby użycia mapy ESRI w prawym dolnym rogu ekranu pojawia się komunikat o błędzie "Usługa serwera jest niedostępna lub nieprawidłowy klucz mapy ESRI".

Przyczyna

Możliwe przyczyny:

  • 26 lutego 2025 r. firma ESRI zmieniła punkty końcowe dla map Ulice ESRI, ESRI Jasny i ESRI Ciemny.

    Podczas korzystania z BricsCAD V24.2.X i V25.1.X podczas próby użycia tych map pojawia się błąd "Usługa serwera jest niedostępna lub nieprawidłowy klucz map ESRI".

  • Klucz API wygasł.
  • Klucz API zawiera adresy URL referentów.

Rozwiązanie

  • Aby rozwiązać ten problem dla wspomnianych wersji BricsCAD, należy ręcznie zaktualizować punkty końcowe w sekcji Usługi Map Online w oknie dialogowym Ustawienia.

    Nowe punkty końcowe powinny być ustawione w następujący sposób:

    • Metadane ulic statycznych: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/streets/static
    • Statyczny kafelek ulic: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/streets/static/tile/{level}/{row}/{column}
    • Statyczny jasnoszary Metadane: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/light-gray/static
    • Statyczny jasnoszary kafelek: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/light-gray/static/tile/{level}/{row}/{column}
    • Statyczny ciemnoszary Metadane: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/dark-gray/static
    • Statyczny ciemnoszary kafelek: https://static-map-tiles-api.arcgis.com/arcgis/rest/services/static-basemap-tiles-service/v1/arcgis/dark-gray/static/tile/{level}/{row}/{column}
  • Aby sprawdzić, czy klucz API wygasł, należy uzyskać dostęp do poświadczeń klucza API. Jeśli klucz wygasł, można wygenerować nowy.
  • Aby sprawdzić, czy klucz API zawiera adresy URL odsyłaczy, należy uzyskać dostęp do poświadczeń klucza API. Jeśli na liście znajdują się jakiekolwiek wpisy, należy je usunąć.
    Uwaga: Aktualizacja odsyłaczy powoduje unieważnienie klucza API. Jeśli zmienisz odsyłacze, musisz również zregenerować istniejący klucz lub wygenerować nowy.

Jak uzyskać dostęp do poświadczeń klucza API

  1. Zaloguj się na swoje konto w ArcGIS Platforma Lokalizacyjna. Kliknij przycisk Zaloguj się (1).
  2. Po zalogowaniu się na pulpicie nawigacyjnym ArcGIS Location Platform przewiń w dół do Poświadczeń programisty (2). Wybierz odpowiedni klucz API i kliknij przycisk Zarządzaj danymi uwierzytelniającymi (3).
  3. Otworzy się nowa karta przeglądarki z kluczem API Overview. Wybierz Ustawienia (4) w prawym górnym rogu strony.
  4. Możesz teraz wyświetlić lub zmodyfikować ustawienia klucza API.

    Przewiń w dół do Klucze API (5), aby sprawdzić datę wygaśnięcia lub do Referenci (6), aby sprawdzić, czy istnieją wpisy na liście.