Jakie pliki należy uwzględnić podczas zgłaszania awarii?

Objawy

Wystąpiła awaria programu lub program często ulega awarii.

Przyczyna

Najbardziej niezawodnym sposobem zgłoszenia awarii jest przedstawienie powtarzalnego scenariusza. Oznacza to, że dostępna jest procedura krok po kroku wraz z dobrze zdefiniowanym kontekstem początkowym. Może to wymagać pewnego wysiłku, aby zrobić to dobrze, ale ma zdecydowanie największe szanse na sukces.

Ogólnie rzecz biorąc, aby scenariusz był powtarzalny, najlepiej zredukować środowisko tak, aby było jak najbardziej standardowe. Jest to proces upraszczania i eliminowania. Jeśli to możliwe, scenariusz powinien zaczynać się od domyślnego profilu użytkownika BricsCAD, nowego rysunku, bez wtyczek innych firm lub dostosowań użytkownika oraz domyślnego pliku CUI.

Jeśli nie jest możliwe podanie powtarzalnego scenariusza, to w niektórych przypadkach możemy wywnioskować wystarczającą ilość informacji z dodatkowych plików diagnostycznych.

Rozwiązanie

Prześlij wniosek o pomoc techniczną wraz z plikami, takimi jak:

  • crash_report.txt.
    Note:
    • Plik crash_report.txt jest tworzony w systemie Windows i, począwszy od BricsCAD V24.2.02, w systemie Linux.
    • W systemie macOS istnieje plik bricscad-RRRR-MM-DD-xxxxxxxx.ips wygenerowany przez system operacyjny.
  • Plik zrzutu awaryjnego (.dmp).
  • Profile użytkowników

    Bieżące ustawienia profilu użytkownika można wyeksportować do pliku za pomocą programu Profile Manager.

  • Plik rysunku.

    Jeśli awaria jest specyficzna dla rysunku, taki rysunek będzie pomocny.

  • Opisz efekt trybu awaryjnego.

    Jeśli problem zniknie podczas pracy w trybie awaryjnym, pomocne może być przełączenie się z powrotem do trybu normalnego i wyłączenie lub odinstalowanie wtyczek i dostosowań, aby zawęzić winowajcę.

  • Plik dziennika Log (rzadko żądany).
Note:

Słowo awaria jest często nadużywane w odniesieniu do innych problemów, więc analityk może zadawać pytania, aby dokładnie określić, co się dzieje. Rozłączenie lub zamrożenie nie jest awarią, a bardzo powolna operacja nie jest rozłączeniem. Operacja, która kończy się niepowodzeniem z powodu błędu, ale nie zamyka BricsCAD, również nie jest awarią.

Raport o awarii jest zapisywany w pliku crash_report.txt za każdym razem, gdy BricsCAD ulega awarii. Raport o awarii jest zapisywany w folderze startowym BricsCAD. Lokalizacja tego folderu zależy od tego, jak uruchomisz BricsCAD, więc pamiętaj, że w twoim systemie może istnieć wiele plików w różnych folderach. Jeśli program nie ma uprawnień do tworzenia pliku w folderze startowym, plik jest tworzony w folderze %HOMEPATH% (w systemie Windows jest to zwykle c:\Users\[nazwa_użytkownika]\). Czasami raport o awarii jest generowany bez zamykania programu. Czasami zdarza się awaria bez raportu o awarii.

(Specyficzne dla systemu Windows) W większości przypadków awaria programu powoduje utworzenie pliku zrzutu awaryjnego (.dmp), który jest generowany w tym samym folderze co crash_report.txt. Tworzenie pliku zrzutu awaryjnego można włączyć lub wyłączyć w zależności od QAFLAGS bit 2048. Przed wersją 18.2 zrzut awaryjny był tworzony tylko wtedy, gdy ustawiono QAFLAGS bit 2048. W nowszych wersjach znaczenie flagi zostało odwrócone, a plik zrzutu awaryjnego jest teraz tworzony domyślnie.

BricsCAD może rejestrować każde wykonane polecenie w tekstowym pliku dziennika. Generowanie tego dziennika jest kontrolowane przez zmienną systemową LOGFILEMODE. Jeśli zmienna LOGFILEMODE = 1, plik dziennika jest tworzony przy każdym otwarciu rysunku. Format nazwy pliku to DrawingName_yyyy-mm-dd_hh-mm-ss.log.

Pliki dziennika Log BricsCAD są zapisywane w folderze określonym przez zmienną systemową LOGFILEPATH. Domyślnie jest to folder wskazywany przez zmienną systemową LOCALROOTPREFIX.