Workspaces

The WORKSPACE command sets the current workspace and lets you create, modify and save workspaces.

The WSSAVE command saves the current workspace under a different name, thus creating a new workspace.

The WSSETTINGS command opens the Customize dialog box at the Workspaces tab.

Workspaces define settings and preferences regarding a specific working environment.

The following workspaces are available:

Workspace License Level
2D Drafting Lite or higher
2D Drafting (Modern) Lite or higher
Modeling Pro or higher
BIM BIM or Ultimate
Mechanical Mechanical or Ultimate
Civil Survey Pro or higher
Ultimate Ultimate
Toolbars (Classic) Lite or higher
Note: The name of the workspace is stored by the WSCURRENT system variable and depends on the current user profile (PROFILEMANAGER command).

Setting the current workspace

Do one of the following:

  • Click the Current Workspace field in the Status bar, then select a workspace in the context menu.
  • Choose a workspace in the Workspaces toolbar.
  • Type WSCURRENT at the command line.

    You are prompted: New value for WSCURRENT <"2D DRAFTING">:

    Type the name of the new current workspace, then press Enter.

Note:
  • If the WSAUTOSAVE system variable is On, upon switching to another workspace, the toolbar positions of the current workspace are saved in the CUI file. The default value for WSAUTOSAVE is On.
  • It is not recommended to switch workspaces if the name of the user profile refers to a workspace.

Managing workspaces

Workspaces are defined in the Workspace tab page on the Customize dialog box.

  1. In the Customize dialog box, click the Workspaces tab.
  2. Expand a workspace.

    A workspace definition you can set:

    • Menus, defines which menus are available.
    • Toolbars defines which toolbars are displayed by default.
    • Panels controls the visibility of dockable panels.

      Right-click a panel, then choose an option in the context menu:

      • Show makes the panel visible.
      • Hide makes the panel not visible.
      • Don't change keeps the current state.
    • Ribbon: defines the available ribbon tabs.
    • Quad Tabs: defines the order and availability of the Quad tabs.
    • On Switch: defines the system variables and user preferences to be set, and the commands to be executed, when switching to the workspace.

Creating a workspace

  1. In the Customize dialog box, click the Workspaces tab.
  2. Do one of the following:
    • Select Workspaces, then right-click and choose Append workspace in the context menu.

      The new workspace will be added below the last existing workspace.

    • Select an existing workspace, then right-click and choose Insert workspace in the context menu.

      The new workspace will be added above the selected workspace.

    The Add workspace dialog box appears.

  3. Type a name in the Name field then press Enter or click the OK button.

    A newly created workspace contains the following items:

    • A standard menu set
    • A standard toolbar set
    • All panels set to Don't change
    • An empty ribbon
    • A default set of Quad tabs
    • An empty On Switch sequence

    The newly created workspace has default properties. These properties are also available in the Settings dialog box, under Program Options / Workspace.

Editing a workspace

  1. In the Customize dialog box, click the Workspaces tab.
  2. Expand the workspace.
  3. (option) Edit the menu set.
    • Change the order by dragging a menu.
    • Delete a menu by selecting the menu and choosing Remove in the right-click context menu.
    • Insert a menu by:
      • Right-clicking a menu in the list and choosing Insert menu in the context menu.

        The File menu is inserted by default.

      • Selecting in the Workspace Menu grid the ID field, then selecting the desired menu in the list.
  4. (option) Edit the toolbar set.
    • Change the order by dragging a toolbar.
    • Delete a toolbar by selecting the toolbar and choosing Remove in the right-click context menu.
    • Insert a toolbar by:
      • Right-clicking a toolbar in the list and choosing Insert toolbar in the context menu.

        The Standard toolbar is inserted by default.

      • Selecting in the Workspace Toolbar grid the ID field, then selecting the desired toolbar in the list.
  5. Edit the properties of the panels.
    • Set the desired 'on switch' behavior by selecting Show, Hide or Don't change.
    • Select a panel, then edit its properties in the property grid.
  6. Edit the composition of the ribbon.
    • To add a tab, right-click an existing tab and choose Insert tab in the context menu, then select the tab in the Select Ribbon Tab dialog box.
    • To remove a tab, right-click the tab and choose Remove in the context menu.
    • To change the position of a tab, drag the tab.
  7. Edit the Quad settings.
    • To change the order of the Quad command groups, press and hold the left mouse button, then drag a command group to its new position.
    • Right-click a Quad command group, then choose Delete in the context menu to remove the command group from the Quad cursor menu.
    • Right-click a Quad command group, then choose Insert and select from the list one of the tabs which you want to add to the Quad cursor menu.
  8. Edit the On Switch procedure.

    To add a command to the On Switch sequence, select the command in the available commands pane and drag it to the On Switch node.

Deleting a workspace

  1. In the Customize dialog box, click the Workspaces tab.
  2. Right-click the workspace and choose Delete in the context menu.

    A Confirm dialog box appears.

  3. Press the Yes button to delete the selected workspace.
Important: You should not delete the default workspace. If the default workspace is deleted, use the Importing a Workspace procedure below to restore the missing workspace from default.cui file in the ../UserDataCache\Support\en_US subfolder of the BricsCAD installation folder.

Importing a workspace

The option in the File menu on the Customize dialog box can import workspaces from another CUI file into the current main CUI.

  1. In the Customize dialog box, choose Import workspaces… in the File menu.

    The Choose a Customization File dialog box appears.

  2. Browse to the folder where the CUI file you want to import the workspace from is saved.

    By default, BricsCAD saves CUI files in the Support folder of the Roamable Root folder. See also the article BricsCAD User Files.

  3. Select the CUI file.

    A dialog box appears, listing all workspaces in the selected CUI file.

  4. Select the workspace(s) to import in the list, then click the OK button.

    Press and hold the Ctrl key to select multiple workspaces.