Areas de trabalho

O comando AREADETRABALHO define a atual área de trabalho, e permite a você criar, modificar e salvar áreas de trabalho.

O comando SALVARAT salva a atual área de trabalho sob um nome diferente, assim criando uma nova área de trabalho.

O comando CONFIGURAAT abre a caixa de diálogo Personalizar na aba Areas de trabalho.

Areas de trabalho definem configurações e preferências considerando a um ambiente de trabalho específico.

As seguintes áreas de trabalho estão disponíveis:

AreaDeTrabalho Nível da Licença
2D Desenho Lite ou superior
2D Desenho (Moderno) Lite ou superior
Modelagem Pro ou superior
BIM BIM ou Ultimate
Mechanical Mechanical ou Ultimate
Civil/Levantamento Pro ou superior
Ultimate Ultimate
Barras (Clássico) Lite ou superior
Nota: O nome da área de trabalho é armazenado pela variável de sistema WSCURRENT e depende do perfil de usuário atual (comando PROFILEMANAGER).

Configurar a atual área de trabalho

Siga um dos procedimentos:

  • Clique o botão-direito no campo Area de Trabalho Atual na barra Status, e selecione uma área de trabalho no menu de contexto.
  • Escolha uma área de trabalho na barra de Areas de trabalho.
  • Digite WSCURRENT na linha de Comando.

    Você será solicitado: Novo valor para WSCURRENT <"2D Desenho">:

    Digite o nome da nova área de trabalho atual, e pressione Enter.

Nota:
  • Se a variável de sistema WSAUTOSAVE estiver Ligada, ao trocar para outra área de trabalho, as posições das barras da área de trabalho atual são salvas no arquivo CUI. O valor predefinido para WSAUTOSAVE é Ligado.
  • Não é recomendável alternar áreas de trabalho se o nome do perfil do usuário se referir a uma área de trabalho.

Gerenciar áreas de trabalho

Areas de Trabalho são definidas na página da aba Area de Trabalho na caixa de diálogo Personalizar.

  1. Na caixa de diálogo Personalizar, clique na aba Areas de trabalho.
  2. Expandir uma área de trabalho.

    Uma definição de área de trabalho que você pode configurar:

    • Menus, define quais menus estão disponíveis.
    • Barras, define quais barras de ferramentas são exibidas por padrão.
    • Painéis, controla a visibilidade dos painéis encaixáveis.

      Clique o botão-direito do mouse num painel, então escolha uma opção no menu de contexto:

      • Mostrar, torna o painel visível.
      • Ocultar, torna o painel não visível.
      • Não alterar, mantém o estado atual.
    • FaixaOpções: define as abas disponíveis na Faixa de opções.
    • Abas do Quad: define a ordem e disponibilidade das abas no Quad.
    • Ao Ativar: define as variáveis de sistema e preferências do usuário a ser ajustadas, e comandos a ser executados, quando trocar para a área de trabalho.

Criar uma área de trabalho

  1. Na caixa de diálogo Personalizar, clique na aba Areas de trabalho.
  2. Siga um dos procedimentos:
    • Selecione Areas de Trabalho, então clique o botão-direito e escolha Acrescentar área de trabalho no menu de contexto.

      A nova área de trabalho será adicionado abaixo do último espaço de trabalho existente.

    • Selecione uma área de trabalho existente, e clique o botão-direito e escolha Inserir Area de trabalho no menu de contexto.

      O novo espaço de trabalho será adicionada acima da área de trabalho selecionada.

    A caixa de diálogo Adicionar área de trabalho é exibida.

  3. Digite um nome no campo Nome e pressione Enter ou clique no botão OK.

    Uma área de trabalho recém-criada contém os seguintes itens:

    • Um conjunto de menu padrão
    • Um conjunto de barras de ferramenta padrão
    • Todos os painéis estão configurados para Não mudar
    • Uma Faixa de opções vazia
    • Um conjunto padrão de abas do Quad
    • Uma sequência vazia em Ao Ativar

    A área de trabalho recém-criada tem propriedades padrão. Estas propriedades também estão disponíveis na caixa de diálogo Configurações, sob Opções do programa / Area de trabalho.

Editar uma área de trabalho

  1. Na caixa de diálogo Personalizar, clique na aba Areas de trabalho.
  2. Expandir a área de trabalho.
  3. (opção) Editar o conjunto de menus.
    • Altere a ordem arrastando um item do menu.
    • Para Excluir um item do menu, selecione o menu e escolha a opção Remover no menu de contexto (botão-direito).
    • Insira um menu por meio de:
      • Clique o botão-direito em um menu na lista e escolha Inserir menu no menu de contexto.

        O menu Arquivo é inserido por predefinição.

      • Selecionar na grade Menu AreaDeTrabalho o campo ID, então selecione o menu desejado na lista.
  4. (opção) Editar o conjunto de barras.
    • Altere a ordem arrastando a barra de ferramentas.
    • Para excluir uma barra de ferramentas, selecione-a e escolha Remover no menu de contexto (botão-direito).
    • Inserir uma barra de ferramentas por meio de:
      • Clique o botão-direito em uma barra na lista, e escolha Inserir barra no menu de contexto.

        A barra de ferramentas Padrão é inserida por predefinição.

      • Selecionando na grade Barra AreaDeTrabalho o campo ID, então selecione a barra de ferramentas desejada na lista.
  5. Editar as propriedades dos painéis.
    • Defina o comportamento desejado do interruptor "Ao Ativar" selecionando Mostrar, Ocultar ou Não mudar.
    • Selecione um painel, e edite suas propriedades na grade de propriedades.
  6. Editar a composição da Faixa de opções.
    • Para adicionar uma aba, clique o botão-direito em uma aba existente, e escolha Inserir aba no menu de contexto, então selecione a aba na caixa de diálogo Selecionar Aba da Faixa de opções.
    • Para remover uma aba, clique o botão-direito na aba e escolha Remover no menu de contexto.
    • Para alterar a posição de uma aba, arraste a aba.
  7. Edite as configurações do Quad.
    • Para alterar a ordem dos grupos de comando no Quad, pressione e segure o botão esquerdo, e arraste um grupo de comando para sua nova posição.
    • Clique o botão-direito num grupo de comando do Quad, e escolha Excluir no menu de contexto, para remover aquele grupo de comandos do menu Quad.
    • Clique o botão-direito em um grupo de comandos do Quad, então escolha Inserir e selecione na lista uma das abas que você deseja adicionar ao menu Quad.
  8. Editar o procedimento Ao Ativar.

    Para adicionar um comando à sequência Ao Ativar, selecione o comando na seção de comandos disponíveis, e arraste-o para o nó Ao Ativar.

Excluir uma área de trabalho

  1. Na caixa de diálogo Personalizar, clique na aba Areas de trabalho.
  2. Clique o botão-direito na área de trabalho, e escolha Excluir no menu de contexto.

    Uma caixa de diálogo Confirmar é exibida.

  3. Pressione o botão Sim para excluir a área de trabalho selecionada.
Importante: Você não deve excluir a área de trabalho predefinida (default). Se a área de trabalho predefinida foi excluída, use o procedimento abaixo Importar uma AreaDeTrabalho para restaurar a área de trabalho ausente a partir do arquivo Default.cui na subpasta .../UserDataCache\Support\en_US da pasta de instalação do BricsCAD.

Importar uma área de trabalho

A opção no menu Arquivo na caixa de diálogo Personalizar pode importar área de trabalho de outro arquivo CUI para o CUI principal atual.

  1. Na caixa de diálogo Personalizar, escolha Importar áreas de trabalho... no menu Arquivo.

    A caixa de diálogo Escolher um Arquivo de Personalização é exibida.

  2. Navegue até a pasta onde o arquivo CUI, do qual você deseja importar a área de trabalho, está salvo.

    Por predefinição, BricsCAD salva os arquivos CUI na pasta Support da pasta Raiz Transportável (Roamable Root). Veja também o artigo Arquivos do Usuário BricsCAD.

  3. Selecione o arquivo CUI.

    Uma caixa de diálogo aparece, listando todas as áreas de trabalho no arquivo CUI selecionado.

  4. Selecione os espaços de trabalho a serem importados na lista e clique no botão OK.

    Pressione e segure a tecla Ctrl para selecionar várias áreas de trabalho.